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Using Déjà Vu Interactive – a tutorial XE "Déjà Vu Interactive" 

 XE "Tutorial" 
Now that you have installed Déjà Vu on your computer, you are ready to begin with our tutorial.

The series of step by step procedures in this chapter goes through the process of translating the specification sheets for two fictitious printers, the ACME SpeedPrint 720 and the SpeedPrint 1440. Although the specifications are entirely made up and not very interesting, translating them will help you become acquainted with some of the features in Déjà Vu Interactive (DVI).

Organizing your files XE "Organizing your files" 
Before you begin using Déjà Vu, the first thing you must do is to organize your work and decide where you are going to store your files (source files, translated files, project files, etc.). Hence, you must create several directories (folders) that will contain:

· source files

· translated files

· project files

· memory databases

· terminology databases

How you structure these directories is a matter of personal choice and preference. The aim is to organize your work in a way that prevents you from getting lost (and losing your files) among the many files that both you and Déjà Vu create.

For the purposes of this tutorial, we recommend the following directory structure:
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Once you have created the directory structure, you should copy the example files from the \Samples subdirectory in the Déjà Vu CD. Copy the file SP720.RTF to C:\My Projects\ACME\Sp720\ Specs
, and SP1440.RTF to C:\My Projects\ACME\Sp1440\Specs.

Configuring Déjà Vu XE "Configuring Déjà Vu" 
If you work with a language that uses a non-Latin character set, such as Russian, Japanese or Hebrew, you must tell Déjà Vu which font and character set to use for the language. If the languages you work with use the Latin alphabet, you can skip this section and go on to the next one.

· To configure the fonts in Déjà Vu

1. Open Déjà Vu Interactive.

2. On the Tools menu, click on Options…
The DejaVu options window XE "Options window"  appears:
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3. Click on Fonts to display the corresponding page:
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Click on the Select language drop-down arrow and select a language.

4. Click on Font Style.

The font selection dialog appears:
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5. Select the font, style, size and script (character set) you want Déjà Vu to use when displaying text in this language. Remember to select the correct script if your language uses a non-Latin alphabet.

6. Click on OK to accept the font settings.

You should be able to see the new font in the Sample Text area of the options window.

7. Configure any other languages you use.

8. Click on OK.

Creating a project XE "Projects:creating" 
Projects are created in Déjà Vu Interactive (DVI); you also use DVI to open projects you have created previously, and to carry out most of the tasks that comprise the translation process in Déjà Vu.

· To create a project

1. Open Déjà Vu Interactive.
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2. On the File menu, click on Create project…, or click on the [image: image6.png]


 button on the tool bar.

3. Click on RTF…
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4. Type Sp720 and click on Save.
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5. The Project configuration window appears.
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6. Fill in the following parameters:

· For Project title, enter ACME SpeedPrint 720.

· Click on the Browse button beside the Source common directory box and select C:\My Projects\ACME\SP720\Specs.

7. Click on Languages to select the corresponding tab.
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8. Click on the Source language drop-down arrow and select English.

9. On the Available languages table, locate the language you want to translate to, and drag it to the Target languages table.

10. Click on the Select/create button beneath the Memory box under Databases for [the target language].
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11. In the file selector, open the directory C:\My Projects\Databases. Enter the name you want for the memory database.

12. Click on Open.

A message box will appear, asking whether you want to create the memory database. Click on Yes.

13. Click on the Select/create button beneath the Terminology box, and create a terminology database in the same way.

14. Click on OK.

Importing the source text file

Once the project has been created and configured, you are ready to import the RTF file containing the specifications for the first printer model.

· To import the source text file

1. On the File menu, click on Import external files, or click on the [image: image12.png]


 button on the tool bar.

2. A window will appear, showing all the RTF files found under the Source common directory.
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3. Double click on \SP720.RTF in the Files found area (or click on Select all).

\SP720.RTF should now appear in the Files to import or reimport column.

4. Click on Go.

DVI will now perform the following tasks:

· Filter the text to make most formatting codes hidden and inaccessible.

· Replace character formatting codes with embedded placeholders that are difficult to delete by accident.

· Split paragraphs into sentences according to the set of rules and exceptions specified in the DejaVu options
 window.

· Build the project file with all the source sentences in a column, and an empty column for the target language.

As DVI imports the RTF file, notice that it displays the text of each sentence in the status bar.

Embedded codes XE "Embedded codes" 
Once DVI has finished importing the RTF file, the DVI Project window should look like this:
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Notice the {1} symbol at the beginning of the first sentence. This is what we call an embedded code. An embedded code contains formatting information that is inside the sentence.

In this case, {1} contains formatting information for the table cell in which the sentence appears. In most cases, you do not need to know what the embedded code contains, as long as you place it in the correct place. For example, if a word has an embedded code on each side, we can probably assume that, in the source text, this word is marked as bold, italics, etc.

For several reasons, it is necessary to display embedded codes. It allows us, for example, to correctly place the corresponding codes in the target sentence, thereby applying the same formatting.

Translating

Now that you have seen what embedded codes are, and the important part they play in DVI, you are ready to begin translating. Naturally, you will start with the first sentence in the file.

· To select a sentence to translate

1. Locate the source sentence in the table.

If you are not at the beginning of the file, use the table scroll bar to move to the beginning, or press Ctrl+PgUp.

2. Click on the sentence in the table.

The full source sentence should appear in the source text box.
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Since the source sentence contains an embedded code at the start, the first thing to do is to copy the embedded code to the target.

· To copy an embedded code

· Press Ctrl+D.

–Or–

· Right-click on the target text box to bring up the context menu
, and click on > Copy first code from source.
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The {1} symbol should have been copied to the target sentence. Now you can type in the translation.

Once you have entered the translation, press Ctrl+( to move to the next sentence
. The background of the target cell in the table will turn light gray to indicate that you have translated this sentence manually
.

The second sentence consists of a product code and name, as well as a couple of embedded codes, so you do not need to translate it. Instead, we will copy the source text directly.

· To copy the current source sentence to the current target

· Press F5.

–Or–

· Click on the [image: image17.png]


 button on the tool bar.

–Or–

· Right-click on the target text box and click on Copy source to target.
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Once you have copied the sentence, press Ctrl+( to advance to the next sentence. Notice that in the status bar, the Position indicator has gone from 1% to 2%. You can use this indicator as a reference of your position inside the project.
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For the third sentence, you may want to copy the source sentence to the target, and then modify it. However you do it, remember to place the correct embedded codes. If you forget to place an embedded code, Déjà Vu Interactive will paint the cell red to warn you.
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On the fourth sentence you will notice that the sentence is split into two, unlike the previous ones. If you look at the RTF file, you will notice that there is a space between the colon (:) and the tab
, which is not present in the two previous lines. While we cannot correct the original RTF file, we can make sure that this does not happen in the translation. To begin with, what we want to do is to join the two lines.

· To join two sentences

1. On the table, click on the first of the two sentences.

2. On the Edit menu, click on Join sentences (or press F3), or click on the [image: image21.png]


 button on the tool bar.

The two sentences should now be joined. When entering the translation, you will probably want to remove the space between the colon and the tab.
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Continue translating until you come to the sentence that reads {11}720 x 720 dpi;. Translate this sentence too. You will notice that the next two sentences are very similar. Naturally, we do not want to translate the same kind of thing twice, so we will use one of Déjà Vu's most useful features: scanning for a sentence.

Before we can look for anything in the memory database, we have to add something to it. Since we want to use the current translation to save us some work, we will send this sentence pair
 to the memory database.

· To send a sentence pair to the memory database

· On the Tools menu, click on Send pair to memory database
–Or–

· Press Ctrl+F12.

–Or–

· Click on the [image: image23.png]


 button on the tool bar.

Once you have added the sentence to the memory database, press Ctrl+(. We are now going to scan the memory database for a sentence similar to the current one (which happens to be the sentence you just translated).

· To scan [the memory database] for a sentence

1. Click on Scan on the Tools menu (or press Ctrl+S), or click on the [image: image24.png]


 button on the tool bar.

A window appears, showing you all the matches that were found, along with the proposed translation for the sentence you were scanning for.
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Notice that Déjà Vu Interactive automatically replaces numbers and removes unnecessary embedded codes from the translation it proposes.

2. Since there is only one match, and it is the one we want, double click on it to paste it into the translation.

Continue translating until you finish the project, and practice using the features we have seen so far.

Finishing the translation

Once you have finished translating, you should send all the sentence pairs in the project to the memory database. This will ensure that everything you have translated will be available for future use, and that any incorrect translations you may have sent during the course of the translation are replaced with the final ones.

· To send all the sentence pairs from the project to the memory database

1. Click on Send project to memory database on the Tools menu (or press Shift+F12), or click on the [image: image26.png]


 button on the tool bar.

The Send what? window appears.
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You have the option of exporting the sentence pairs for the current language, or all the target languages in the project. Since our project only contains one target language, both options have the same effect.

2. Select the current target language.

3. Check the Delete all pairs previously sent from the project option.

4. Click on OK.

Since for a large project sending all the sentence pairs can be a time consuming operation, DVI displays the progress in the status bar:
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After sending the whole project to the memory database, the final step is to export the project, i.e., to generate the translated RTF file.

· To export the finished translation

1. On the File menu, click on Export finished translations…, or click on the [image: image29.png]


 button on the tool bar.

The Export what? window appears.
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Since there is only one target language and only one file, none of the options is available.

2. Click on OK.

DVI will first validate all the translated sentences, checking for problems with embedded codes and other details that could cause problems in the output file.

Once the validation stage is finished, DVI will recreate the directory structure under the Source common directory we specified when configuring the project, prepending the ISO code for the language name. For example, if you were translating the file into German, the new directory would be called C:\My Projects\ACME\SP720\de_Specs.

Doubling your productivity

In the previous section you had to translate the project manually. This should not have been exceedingly difficult, but you could have done it just as well in your word processor; your work may have been made more comfortable by hiding all formatting and layout information, but that is all. We have not made any use of the translation memory features; of course, until you sent the translation to the memory database there was nothing in it which we could use. Now that you have completed your first project, there should be enough material to demonstrate some of the interesting features in Déjà Vu.

You have translated the specifications sheet for the ACME SpeedPrint 720, and we will now translate the specifications for the new SpeedPrint 1440 model—in a fraction of the time it took to translate the first sheet.

As with any other translation job, you should begin by creating a new project.

1. Follow the explanation we presented earlier in this tutorial, but select C:\My Projects\ACME \SP1440\Specs as the Source common directory when configuring the project.

Notice that when you select the target language, Déjà Vu remembers the last memory database and terminology database you used, and offers them as default.

2. Import the RTF file in the same way as for the previous project.
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Pretranslating XE "Pretranslating" 
This time, rather than translating the file manually, we are going to let Déjà Vu carry out a pretranslation. A pretranslation involves examining the text we are about to translate and, for each sentence in it, scanning the memory database for similar sentences we have translated in the past; Déjà Vu will take the most similar sentence (whether it is an exact
 match or a fuzzy one) and insert it in the corresponding location of the translation.

· To pretranslate a project

1. On the Tools menu, click on Pretranslate… (or press Ctrl+R), or click on the [image: image32.png]


 button on the tool bar.

The Pretranslate options? window appears.
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2. Set the different options as shown above and click on OK.

Since for a large project pretranslating can be a time consuming operation, DVI displays the progress in the status bar.
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Voilà! The pretranslation is finished, and Déjà Vu has done almost all of the work for you.
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You will notice that most of the target cells are painted either green or magenta. In the same way it painted target cells red when there was a problem with embedded codes, DVI paints a cell green when it has inserted an exact match, and magenta when it has inserted a fuzzy match.

Even if Pretranslate inserts an exact match, it is good practice to check the translation for any mistakes (you might have translated it wrong in the past!). Naturally, you should check and edit all the fuzzy (magenta) matches; remember to press Ctrl+( after you translate each one.

Assembling from pieces XE "Assemble from portions" 
If you look at the sentences that Pretranslate has left empty, you will see that almost all of them are completely new to DVI, i.e., there is nothing similar to them in the memory database. There are also several sentences that consist almost entirely of figures and acronyms. We will use the Assemble feature, one of the most powerful in Déjà Vu's most versatile features, to try to translate these.

Let's repeat the pretranslation, but this time we will let Déjà Vu translate, not just complete sentences, but also smaller portions, and if necessary word by word.

· To pretranslate with 'Assemble from portions' enabled

1. On the Tools menu, click on Pretranslate… (or press Ctrl+R), or click on the [image: image37.png]


 button on the tool bar.

The Pretranslate options? window appears.
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2. Set the different options as shown above:

Check the Assemble from portions option.

Check the Insert source text for failed portions option. This will make Déjà Vu insert acronyms and other unknown words into the target as they appear in the source text.

3. Click on OK.
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You will find that the first three translations inserted by Assemble (all marked in magenta) are probably not too useful. However, the fourth, {15}45 dB(A) (ISO 7779), contains only figures, single letters and acronyms, so Assemble has generated a translation. If you move further on, you will see that, where plain Pretranslate was unable to translate Support, Assemble has. This is because plain Pretranslate only considers the sentence as a whole, while Assemble goes down to the word level.

After using both varieties of Pretranslate, with and without Assemble, you should have had to translate only about six sentences and edit a dozen or so fuzzy matches.

Note. We have asked you to pretranslate the document in two stages in order to illustrate the effects of Assemble. In real life jobs you will probably run Pretranslate with Assemble enabled, but this may depend on the nature of your source documents and the material already available in the databases. There will be situations in which you don't want DVI to retrieve fuzzy matches for whole sentences; this is achieved by checking the Accept only exact matches when scanning on the Pretranslate options window.
Charging your client XE "Word count" 
If this were a real job, you would probably want to count the number of words and characters you had translated, in order to charge your client accordingly; nothing could be simpler in DVI.

· To count the words and characters in the project

1. On the Tools menu, click on Count words and characters.

The Word and character count window should appear.
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You will notice that there are options that allow you to generate a very detailed word count, listing different types of matches separately. This will prove useful when assessing the progress of a translation.

2. If you want to save the output of the word count to a text file, click on Save and select a file name.

That's all folks

You can send the project to the memory database and export the translation if you want to see the results.

By now, you should be familiar with the Déjà Vu Interactive environment, and ready to begin translating real files on your own.































� If you created a directory structure different from the one we have recommended, place the files in the appropriate directories.


� In most cases, the default sentence splitting rules should be valid. For more information on sentence splitting rules, see � REF _Ref431204492 \h � \* MERGEFORMAT �Configuring Déjà Vu� on page � PAGEREF _Ref431204492 \h ��1�.


� You will find that most of the common actions associated with an object will appear in a popup context menu when you right click on it.


� You can also select the next sentence on the table. However, pressing Ctrl+( keeps the target text box active, making it easier and quicker to move to the next sentence; it also validates the embedded codes in the target sentence.


� A light gray background on a table cell, in general, indicates that you have edited that translation.


� By default, Déjà Vu will split after a colon followed by a space, but not after a colon followed by a tab. You can, of course, change these rules in the Options window. For more information, see � REF _Ref431204492 \h � \* MERGEFORMAT �Configuring Déjà Vu� on page � PAGEREF _Ref431204492 \h ��1�.


� In this manual, we will always refer to a pair of source and target (translated) sentences as a sentence pair.


� An exact match is one in which the source sentence found is identical to the sentence we were searching for. A fuzzy match is a sentence which is similar, but not identical, to the one we were looking for.





