Subject: spider bug(?)

From: [email-masked]
Date: Thu, 20 Jul 89 18:18:23 EDT

If foo.web is:
----------
@* Oink.

@<Oink |#include|s@>=
#include <oink.h>
----------

Then foo.tex (produced by ceeweave) is:
----------
\input cweb.tex

\N1.  Oink.

\Y\P\4\X1:Oink s\X${}\S{}$\par
\fi

\inx
\:\\{include}, 1.
\:\\{oink}, 1.
\fin
\:\X1:Oink s\X
\con
----------

Notice that the module name which should be "<Oink #includes>"
cleverly formated ends up being just "<Oink s>".  (Also, I'm no longer
using gawk!)

^.-.^ Mark Purtill		[email-masked]  (617)623-6238 - H
((")) Dept. of Math, MIT 2-229, Cambridge, MA  02139  (617)253-1589 - O

---

From: nr (Norman Ramsey)
Date: Thu, 20 Jul 89 18:43:44 EDT

This is a bug.  A production is matching a token that isn't
there, and for some reason this is making WEAVE drop all its
text.  I haven't found a quick workaround; you'll have to put
something else in that title (it needs a newline to terminate 
the #include, and it can never get one within @<...@>).

I'll let you know when I get the bug fixed.

Norman