Subject: spiderweb bug report

From: [email-masked] (Ed Kademan)
Date: Thu, 8 Jun 89 14:28:47 CDT

In case you haven't heard of this one yet, two of the line directives in
the file WEBROOT/master/common.c did not have any space between the number
and the file name string.  GNU C would not compile it as a result.  The
lines were numbers 168 and 170 I believe:
----------------------------------------------------------------------
#line 187"/u/nr/src/web/master/pathopen.web"

#line 188"/u/nr/src/web/master/pathopen.web"
----------------------------------------------------------------------
===> Bundled 11 Apr 89; all bugs into patches/003

---

From: nr (Norman Ramsey)
Date: Sat, 17 Jun 89 11:07:51 EDT

I haven't heard of this one yet; thanks for the report.  The problem is that
TANGLE tries to be clever about removing ``unnecessary'' spaces from its input.
The lines you found were from a .h file that was @included.  Since I'm spending
my time writing new literate programming tools, I'm not going to attempt to fix
it.  You can work around it by running the code through a sed script:
	/^#line/s/"/ "/

Good luck.

Norman
	From [email-masked] Thu Jun  8 15:30:58 1989
	Received: from princeton.Princeton.EDU by notecnirp.Princeton.EDU (5.51/1.81)
		id AA12073; Thu, 8 Jun 89 15:30:56 EDT
	Received: from bayes.stat.wisc.edu by Princeton.EDU (5.58+++/2.17)
		id AA00826; Thu, 8 Jun 89 15:30:47 EDT
	Date: Thu, 8 Jun 89 14:28:47 CDT
	From: [email-masked] (Ed Kademan)
	Message-Id: <[email-masked]>
	Received: by bayes.stat.wisc.edu; Thu, 8 Jun 89 14:28:47 CDT
	To: [email-masked]
	Subject: spiderweb bug report
	Status: RO